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Excel 2010       WORKSHEET DATA ENTRY    

 
 

Automatically Repeat Items in a Column 

As you enter data, if the first few characters match an existing entry in that column, Excel 

automatically enters the remaining characters for you. Only entries containing text or a combination 

of text and numbers are repeated; not entries that are only numbers, dates, or times. 

 To accept the entry, press ENTER. 

 To replace the automatically entered characters, continue typing.  

 To delete the automatically entered characters, press BACKSPACE. 

 

 To disable this function, choose Excel OPTIONS, the ADVANCED tab, and clear Enable 

AutoComplete for cell values. 

 Instead of typing, you can choose from items already in the column by right-clicking the cell 

and choosing Pick from Drop-down List. 

 

 

Use the Fill Handle 

 

Fill data into adjacent cells 

1. Select the cells that contain the data that you want to fill into adjacent cells. 

2. Drag the fill handle across the cells that you want to fill. 

 

 You can also click the fill button on the EDITING group or press CTRL + D or EDIT > FILL 

>RIGHT or CTRL + R. 

 

Fill formulas into adjacent cells 

1. Select the cell that contains the formula that you want to fill into adjacent cells. 

2. Drag the fill handle across the cells that you want to fill. 

 

 You can automatically fill a formula downward for all adjacent cells by double-clicking the fill 

handle on the first cell that contains the formula. 

 

Auto-fill Options 

The Auto Fill Options button appears after you drag the fill handle and allow you to choose 

how to fill the selection > Fill Formatting Only or Fill Without Formatting. 

 

 

  

  

 

Fill handle 
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Fill in a Series (numbers, dates, days, weekdays, months, years) 

1. Select the first cell in the range that you want to fill. 

2. Type the starting value for the series (of numbers, dates) 

3. Type a value in the next cell to establish a pattern. 

4. Select the cell or cells that contain the starting values and establish the series pattern. 

5. Drag the fill handle down or to the right.   To fill in decreasing order, drag up or to the left. 

When you fill a series, the selections are extended as shown in the following table. Items 
separated by commas are in placed in individual adjacent cells. 

Initial selection Extended series 
1, 2, 3 4, 5, 6,... 

9:00 10:00, 11:00, 12:00,... 

Mon Tue, Wed, Thu,... 

Monday Tuesday, Wednesday, Thursday,... 

Jan Feb, Mar, Apr,... 

Jan, Apr Jul, Oct, Jan,... 

Jan-99, Apr-99 Jul-99, Oct-99, Jan-00,... 

15-Jan, 15-Apr 15-Jul, 15-Oct,... 

1999, 2000 2001, 2002, 2003,... 

1-Jan, 1-Mar 1-May, 1-Jul, 1-Sep,... 

Qtr3 (or Q3 or Quarter3) Qtr4, Qtr1, Qtr2,... 

text1, textA text2, textA, text3, textA,... 

1st Period 2nd Period, 3rd Period,... 

Product 1 Product 2, Product 3,... 

 

 You can also specify the type of series by using the right mouse button to drag the fill 

handle over the range and then clicking the appropriate command on the shortcut 

menu.  For example, if the starting value is the date JAN-2012, click Fill Months for the 

series FEB-2011, MAR-2011, and so on; or click Fill Years for the series JAN-2011, JAN-

2012, and so on. 
 

 

  Right-click Fill sub-menu  
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 If the selection contains numbers, you can control the type of series that you want to create.  

1. Click the pull-down arrow on the FILL button on the EDITING group and 

choose SERIES.  

2. Under Type, specify the options that you want to use.   

 You can get this same sub-menu by using the right mouse button to pull down the fill 

handle. 

 A Linear series is calculated by adding the value in the Step Value box to each cell 

value in turn.  

 A Growth series is calculated by multiplying the value in the Step Value box by each 

cell value in turn.  

 A Date series fills date values incrementally by the value in the Step Value box and 

dependent on the unit specified under Date unit.  

 An Auto Fill series produces the same results as dragging the fill handle. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 To suppress Auto Fill, hold down the CTRL key while you drag the fill handle. 
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Fill data by using a custom fill series 

A custom fill series can be based on a list of existing items on a worksheet, or you can type the list 

from scratch. 

 

Use a custom fill series based on an existing list of items  

1. On the worksheet, select the list of items that you want to use in the fill series.  

2. Click on File tab, Excel Options, Advanced, General group, Edit Custom Lists.  

3. Verify that the list of items that you selected is displayed in the Import list from cells box, 

and then click Import.  The items in the list that you selected are added to the Custom lists 

box. 

4. On the worksheet, type the item in the custom fill series that you want to use to start the 

list.  

5. Drag across the cells that you want to fill.  
 

 

 

 

 

 

 

 

 

 

 

 

 

Use a custom fill series based on a new list of items  

1. Click on File tab, Excel Options, Advanced, General group, Edit Custom Lists. 

2. In the Custom lists box, click New list, and then type the entries in the List entries box, 

beginning with the first entry.   Press ENTER after each entry. 

3. When the list is complete, click Add.  

4. On the worksheet, type the item in the custom fill series that you want to use to start the 

list.  

5. Drag the fill handle across the cells that you want to fill.  
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Play back worksheet data 

Note: You must have speakers installed to perform this procedure. 

 

Play back a group of cells 

1. Click the pull-down arrows on the Quick Access Toolbar and choose MORE COMMANDS. 

2. From the list ALL COMMANDS, click on SPEAK CELLS and add to toolbar on right. Click OK. 

3. Select a group of cells to read back.  

4. Choose how the computer will read back your data by clicking  the appropriate icon - By 

Rows  or By Columns  on the Quick Access Toolbar.  

5. Click Speak Cells  if you want the computer to read back each cell in your selection.  

 To correct an error, click Stop Speaking , and use your mouse and keyboard to make the 

necessary changes.  

 Click Speak Cells  to continue having the computer read back your selection.  

 

 You can select a specific range of cells for the computer to read back to you, or you can 

click Speak Cells  without selecting any cells and Microsoft Excel will automatically 

expand the selection to include neighboring cells if there are no empty cells in the range. 

 

 If you hide the Text To Speech toolbar and you have not turned off Speak On Enter , the 

computer continues to read back each cell entry you make. Be sure to click Speak On 

Enter to turn it off. 
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 Excel 2010         FORMULAS &  FUNCTIONS     

 

Formulas 

An equation that describes what should appear in a cell. 

 Begins with an equals sign ( = ). 

 Can use numbers, cell references or a combination of the two. 

 Work with math operators: exponentiation (^), multiplication (*), division (/), addition (+), 

subtraction (-). 

Examples:  =A1  =A1+1           =A1/A2 

 

Order of Operations 

1. First actions are done to those in parentheses. 

2. Exponentiation (^). 

3. Multiplication (*) or Division (/). 

4. Addition (+) or Subtraction (-). 

 

Functions 

Math operation (or group of operations) that has a textual name (such as SUM or AVERAGE). 

 Allow Excel to perform complicated math operations simply. 

 Can operate on ranges of cells. 

Examples:  =SUM(A1:A50)  =COUNT(A1:B5)

 =AVERAGE(A1:B20) 

 The parameters of a function are called its arguments. 

 Each function must be followed by a set of parentheses in which the arguments are placed. 

 Some arguments are required; some are optional. 

 If a function contains more than one argument, separate with commas within the 

parentheses. 
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Insert Function 

 

1. Click Insert Function on the Formulas Tab in the 

Function Library group 

2. Select the function from the list. 

 For help in selecting a function, type in key 
words and press GO. 

 

 

 

The Function Arguments box appears. 

1. Enter the required arguments 

indicated by bold lettering. 

2. Type in the range of cells or click on 

the browse button to select the cells 

on the worksheet itself. 

 

  

 For clarification about a function, click on Help on this function. 

 

 

 

 

 

 

 

 

 

 

  

Browse  

button 
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Cell References 

 

Relative references    A relative cell reference in a formula, such as A1, is based on the relative 

position of the cell that contains the formula and the cell the reference refers to. If the position of 

the cell that contains the formula changes, the reference is changed. If you copy the formula across 

rows or down columns, the reference automatically adjusts. By default, new formulas use relative 

references. For example, if you copy a relative reference in cell B2 to cell B3, it automatically adjusts 

from =A1 to =A2. 

 

                               Copied formula with relative reference 

 

Absolute references    An absolute cell reference in a formula, such as $A$1, always refer to a 

cell in a specific location. If the position of the cell that contains the formula changes, the absolute 

reference remains the same. If you copy the formula across rows or down columns, the absolute 

reference does not adjust. By default, new formulas use relative references, and you would need to 

switch them to absolute references. For example, if you copy an absolute reference in cell B2 to cell 

B3, it stays the same in both cells =$A$1. 

 

                               Copied formula with absolute reference 

 

Mixed references    A mixed reference has either an absolute column and relative row, or 

absolute row and relative column. An absolute column reference takes the form $A1, $B1, and so 

on. An absolute row reference takes the form A$1, B$1, and so on. If the position of the cell that 

contains the formula changes, the relative reference is changed, and the absolute reference does 

not change. If you copy the formula across rows or down columns, the relative reference 

automatically adjusts, and the absolute reference does not adjust. For example, if you copy a mixed 

reference from cell B2 to C3, it adjusts from =A$1 to =B$1. 

                                   Copied formula with mixed reference 

 

 

 

 When choosing cells to include in an argument, use the F4 key to choose the cell reference. 
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The Name Manager 

Using named cells and ranges offers a number of advantages: 

* Names make your formulas more understandable and easier to use, especially for people 

who didn't create the worksheet. Obviously, a formula such as =Income-Taxes is more 

intuitive than =D20-D40. 

* When entering formulas, a descriptive range name (such as Total_Income) is easier to 

remember than a cell address (such as AC21). And typing a name is less likely to result in an 

error than entering a cell or range address. 

* You can quickly move to areas of your worksheet either by using the Name box, located on 

the formula bar (click the arrow for a drop-down list of defined names) or by choosing Home 

/ Editing  / Find & Select / Go To (or F5) and specifying the range name. 

* When you select a named cell or range, its name appears in the Name box. This is a good way 

to verify that your names refer to the correct cells. 

* You may find that creating formulas is easier if you use named cells. You can easily insert  a 

name into a formula by using the Formulas  / Defined Names  / Use in Formula  command. 

To display the Name Manager, choose Formulas / Defined Names / Name Manager.  
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Common Formula and Function Errors 

 

Not putting in all required arguments 

 WHY:  Occurs when a function is expecting more arguments than you have entered. 

 FIX:   Make sure you are entering all of the required arguments (indicated by bold). 

  Make sure you have entered commas between the arguments. 

 

 

 

 

 

Circular reference 
 WHY: You have included the cell in which the function is being written within the function 

argument. 

 FIX: Remove the cell reference for the cell in which the function appears. 

 

 

 

 

 

 

Text in an argument (#NAME?) 

 WHY: Most functions require numeric arguments.  

 FIX: Remove the text or name the range to which you would like to refer with a text label. 

 

 

 

Hash marks (###) in a cell 

 WHY: The cell is not wide enough to display the value. 

 FIX: Widen the column. 
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Excel 2010       SORT &  FILTER   
 

Find and Replace Worksheet Data 

 

1. In the Editing Group, choose Find .  The Find and Replace Dialog box appears. 

2. In the FIND area, enter the text or number sequence that you are looking for in the 

worksheet. 

3. Click Find Next.  The cell selector jumps to the first cell containing the matching information. 

4. Click Find All.  A list appears showing all of the occurrences of the string in the worksheet. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Click Options to put more delimiters on the search. 

 Within:  Where to conduct the search – this worksheet or whole workbook?.  Default is 

the current sheet. 

 Search:  In what order do you want the search to proceed - by row or column? 

 Look In:  Select formulas, values, or comments.  Default is Formulas. 

 Match case:  Do the search results need to match the case in which you entered the data 

string? 

 Match entire cell contents:  If the cell contains more than just the search string, it will 

not show up in the results.  For instance, if you chose this option and searched for 101, 

the cell with 1010 would not appear in the results. 
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6. Click the Format drop-down list. 

 Format: Opens a Find Format dialog box. 

 Choose Format From Cell:  Select an existing cell as an example of the formatting you 

want to find. 

 Clear Find Format:  Removes any formatting criteria from your search. 

 

7. Choose any format options which you would like to add to the search.   

 If you are searching for only formatted cells (no particular cell entry information), 

remove any data string in the original Find box. 

 Remember to clear any formatting that you set up before starting the next search by 

clicking on No Format Set. 

 

8. Use the options on the REPLACE tab to perform similar to the FIND functions. 

 You can indicate a data string in the search parameters and replace each item one-by-

one or globally with Replace All. 
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Sort Worksheet Data 

 

Sort Buttons 

1. Choose a column of data. 

2. Click the Sort Ascending or Sort Descending button on the Data tab’s Sort & Filter group or 

on the Home tab/Editing Group/ Sort/Filter. 

 If 2 or more columns are chosen, only the leftmost column will sort. However, the data in 

the adjacent columns will stay synchronized. 

 

Sort Dialog Box 

To perform a multi-column sort: 

1. Select the data range you wish to sort. 

2. Click the Sort icon 

3. Select the column to be used for the primary sort; ascending or descending. 

4. Select the second and third sort fields (if you so desire) by adding levels. 

5.  Indicate if your chosen data includes your Header Row or not. 

6. Click OK to sort 

 

Filter Worksheet Data 

AutoFilter 

1. Select the data you want to filter. 

2. Choose the Filter icon on the Sort & Filter group. 

3. Select the columns on which you would like to 

apply a filter.  Drop down arrows appear on the 

column headers. 

4. Choose a drop-down arrow and a parameter in 

the list.  Only items matching that parameter will 

appear.   

 Filters can be combined (column to column) 

to narrow down your filtered results. 

5. Select the Filter icon to turn off the filtering. 
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Splitting Data 

 

1. Choose the data cells you wish to split into 2 

separate cells. 

2. Add (or make sure there is) a blank column to 

the right of the cell(s) to be split. 

3. Choose Text to Columns in the Data Tools group 

on the Data tab. 

4. On the Convert Text to Columns Wizard, choose Delimited and click Next. 

 

 

 

 

5. Click on the type of delimiter that your text or 

data in the cell is separated by (most likely a 

space). Click Next to continue. 

 

 

 

 

 

 

6. On Step 3, if you want to apply special 

formatting to either of the new columns, indicate 

such now. 

 

 

7. Click Finish. 
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Merging Cells 
Merge cells into one ‘merged’ cell by: 

1. Select the adjacent cells you desire to merge. 

 Caution: only the contents of the upper leftmost 

cell will be retained. 

2. Click on the Merge and Center button in the 

Alignment group on the Home tab. 

3. Align the contents of the new cell by using the text 

alignment buttons on the Formatting toolbar. 

 

To un-merge cells: 

1. Choose the merged cell. 

2. Click on the Merge and Center button 

 Caution: make sure your cursor is not blinking within the merged cell while trying to un-

merge it. 

 

 

Combining Cell Contents (Concatenate) 
Combine (link together) the contents of one cell with another by: 

1. In a new column, enter the concatenation function: =CONCATENATE(cellA,", ",cellB) 

 You can also write this manually: =cellA&" "&cellB (the & being the concatenation 

operator) 

 Whatever is set between the double quotes  

(i.e. a space, a comma, a comma and a space) will 

be exactly what Excel will put in the cell. 

 The formula can be copied to the adjacent 

rows. 

 

Note: the data that shows in each cell is simply a result of the formula shown in the Formula Bar. 

 

To make the data in the new cells permanent, you must copy over the actual values of the previous 

cells from which they were created. 

1. Create a new column next to your new combined/concatenated column. 

2. Copy the formulas from the combined column. 

3. Right-click the cell and choose Paste > Special > Values. 

4. Delete the original combined column (the one containing only the formulas). 
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Excel 2010    MULTIPLE WORKSHEETS &  WORKBOOKS   
 

Working with Worksheets 
Right click a sheet tab for the submenu 

 Insert: New sheet appears to the left of the current worksheet. 

 Delete: Deletes the current worksheet.   

 Undo operation does not work. If deleted in 

error and before you save the workbook, 

close the workbook and open the last known 

good workbook with that worksheet intact. 

 Rename: Suggest short name with no spaces for easy 

reference. 

 Move or Copy: Choose to move to another 

workbook or to another location within the same 

workbook.  Click Create a Copy if you want the 

worksheet copied, not just moved.  

 Use Click and Drag for simple re-ordering. Follow the caret guideline. 

 Select all Sheets: All sheets in this workbook are chosen.   

 Tab Color: Select color for tab. When worksheet is active, colorbar will show. 

 

Hiding & Unhiding Worksheets 

 To hide the current worksheet, right click on the sheet and select Hide. 

 To un-hide a worksheet, right-click on the sheet, select Unhide and choose a hidden 

worksheet. 

 

 

Changing the Default Number of Worksheets 

By default, three worksheets are opened by Excel.  If more are needed, they can be added to the 

open workbook.   

To change the default: 

1. Click on the File tab,Options, General tab. 

2. Indicate the new number of default worksheets 

to open in the  Include this many sheets. 
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Referring to a Cell on a Different Worksheet 

 Precede the name of the cell with the sheet name, followed by an exclamation point: 

=Sheet1!A1 

 If a sheet name has a space in it, enclose the name of the sheet with a single quote: 

  ='My Worksheet'!A1 

 

 

Formulas and Functions 

1. Enter the = and formula designation or function name to begin. 

2. At the point where you want to reference a cell or range on another worksheet,  

a. Click the tab of the worksheet on which the cell or range is located. 

b. Select the cell or range. 

c. Click the tab of the original worksheet and finish the formula or arguments or press 

Enter to finish. 

 

 

Creating a 3-D Reference 

Use a 3-D range in a function to refer to the same cell on multiple worksheets. 

1. Type = to start the function and type up to the point where you want to reference the cell 

range. 

2. Select the tab on the first worksheet on which the first cell resides. 

3. Select the cell. 

4. Hold down the Shift key, then click the tab of the last worksheet on which the cell resides. 

 The corresponding cells on the worksheets in-between these two will be selected. 

5. Return to the original worksheet and complete the function or press Enter to finish. 

 Example of 3-D Reference: =SUM(Sheet2:Sheet13!B5) 

 Note: because you have established a range between worksheets, this will not work with 

a formula. 
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Excel 2010                      CUSTOM HEADERS &  FOOTERS   
  

 

Custom Headers and Footers 

1. Click the View tab. 

2. Select Page Layout. 

3. Click in the area marked Click to add header or Click to add footer. 

4. Choose where you want the text to be, left, center or right aligned. 

5. Type the desired text in the appropriate box. 

6. Click the Home tab to apply formatting to the text (font, bold, underline, or color). 

 

 


